robot framework自动化测试工具装配

robot framework自动化测试工具安装
学习robot-framework(-)

##robot framework 安装步骤:

1、下载软件包:
  • python-2.7.14.msi --python
  • robotframework-2.8.7.tar.gz --RF框架
  • robotframework-ride-1.5.tar.gz --RIDE是图形界面,编写自动化用例软件
  • wxPython2.8-win32-unicode-2.8.12.1-py27.exe --wxpython是python的GUI库,RIDE是基于此库开发的
  • chromedriver.exe --谷歌浏览器驱动,我百度云中的驱动版本是2.36,对应chrome v63-65

>> 相关软件信息请参照,转载:https://www.cnblogs.com/fnng/p/3871712.html
>> 这里提供我整理的软件包,百度云:https://pan.baidu.com/s/1QfBeICiTPBNLNug3BWm8TQ

2、安装python
  • 安装python-2.7.14.msi
  • 将python设置环境变量,如将C:Program Files (x86)python2.7.14 与 C:Program Files (x86)python2.7.14Scripts 放入系统Path中
  • python --version  与  pip --version


3、安装配套软件
  • 打开cmd命令控制器
  • 解压robotframework-2.8.7.tar.gz -> cd此目录 -> python setup.py install
  • 解压robotframework-ride-1.5.tar.gz -> cd此目录 -> python setup.py install
  • 双击安装wxPython2.8-win32-unicode-2.8.12.1-py27.exe(请使用默认目录)


4、安装ride的关键字库
  • 打开cmd命令控制器
  • pip install selenium
  • pip install robotframework-selenium2library


5、chromedriver.exe放入python-home目录下,如C:Program Files (x86)python2.7.14

6、双击 ride.py(如果桌面没有,类似目录寻找C:Program Files (x86)python2.7.14Scriptsride.py)

7、将Selenium2library库导入ride中


8、异常问题
  • 'chromedriver' executable needs to be in PATH,chromedriver驱动的home目录没有放到系统环境变量里;对了我百度云中的chromedriver.exe版本对应chrome版本是65,如果与你的chrome浏览器版本不一致,请自己下载:
  • 驱动下载:http://npm.taobao.org/mirrors/chromedriver/,
    版本对照表:https://blog.csdn.net/huilan_same/article/details/51896672

相关内容推荐