Jenkins或Maven构建时avalon-framework-api-4.1.5-dev无法下载或出错

Jenkins或Maven构建时avalon-framework-api-4.1.5-dev无法下载或报错
在直接用maven构建或使用Jenkins构建项目时,经常会遇到avalon-framework-api-4.1.5-dev.pom无法下载的错误,这是由于中央仓库没有4.1.4-dev版本的jar包及POM文件,针对此文件的解决方法为下:
1. 修改本地仓库中的的xml文件,把.m2/repository/avalon-framework/avalon-framework-api/里所有的xml文件,把4.1.5-dev删除,并将版本修改为4.3.

  avalon-framework
  avalon-framework-api
  4.3
 
   
      4.1.5
      4.1.5-RC2
      4.1.5-RC3
 
      4.2.0
      4.3
   

 


2. 把仓库下的m2/repository/avalon-framework/avalon-framework-api/4.1.5-dev/文件夹删除。
3.刷新maven配置.

相关内容推荐