The android gradle plugin version 2.3.0-alpha1 is too old, please update to the latest version.解决办法

完整的错误提示

Error:(1, 0) The android gradle plugin version 2.3.0-alpha1 is too old, please update to the latest version.

To override this check from the command line please set the ANDROID_DAILY_OVERRIDE environment variable to "f9bad52c24a6e23b3fc85990bc02e3fd7f9dc91c"
<a href="openFile:/Users/targetcloud/Desktop/RN/TGMeituan/android/app/build.gradle">Open File</a>

截图如下

点击工具栏中的Project Structure按钮


或FIle-〉Project Structure

出现下面的图

我们可以在这里把前面两个版本分别改为目前最新的版本号3.2    2.3.0-beta1

那么相关的build.gradle等文件就改成以上版本

classpath 'com.android.tools.build:gradle:2.3.0-alpha1'
-〉

classpath 'com.android.tools.build:gradle:2.3.0-beta1'

附,另外下载最新的AS为

https://dl.google.com/dl/android/studio/ide-zips/2.3.0.3/android-studio-ide-162.3573574-mac.zip

相关内容推荐