传奇类脚本前期准备工作

前言:天使插件,步骤(绑定窗口-开启多线程-测试)

第一步:设计

设计窗口

第二步:代码实现

传奇类脚本前期准备工作

代码(1)

代码(2)

代码(3)

代码(4)

测试

具体代码如下:

.版本 2

.支持库 xplib

.支持库 spec

.支持库 EThread

.程序集 窗口程序集1

.程序集变量 TS, 类_天使

.程序集变量 窗口数组, 整数型, , "0"

.程序集变量 许可证, 线程许可证

.程序集变量 Hwnd, 整数型

.程序集变量 线程句柄, 整数型

.子程序 __启动窗口_创建完毕

.局部变量 返回值, 整数型

XP风格 (1)

寻找窗口 (“Game.dat”)

返回值 = TS.SetPath (取运行目录 ())

调试输出 (“设置全局录制返回值:”, 返回值)

.子程序 寻找窗口

.参数 进程名, 文本型

.局部变量 进程名数组, 文本型, , "0"

.局部变量 进程ID数组, 整数型, , "0"

.局部变量 进程数量, 整数型

.局部变量 i, 整数型

进程数量 = 进程_枚举 (进程名数组, 进程ID数组)

.计次循环首 (进程数量, i)

.如果真 (进程名数组 [i] = 进程名)

加入成员 (窗口数组, 进程_ID取窗口句柄 (进程ID数组 [i]))

.如果真结束

处理事件 ()

.计次循环尾 ()

.如果真 (取数组成员数 (窗口数组) > 0)

.计次循环首 (取数组成员数 (窗口数组), i)

组合框1.加入项目 (“第” + 到文本 (i) + “窗口,标题:” + 窗口_取标题 (窗口数组 [i]), )

.计次循环尾 ()

组合框1.现行选中项 = 0

.如果真结束

.子程序 _按钮1_被单击

.局部变量 绑定值, 整数型

Hwnd = 窗口数组 [组合框1.现行选中项 + 1]

绑定值 = TS.BindWindow (Hwnd, “gdi”, “windows”, “windows”, 0)

调试输出 (“窗口绑定返回值:”, 绑定值)

.如果 (绑定值 = 1)

许可证 = 线程_创建许可证 ()

线程句柄 = 线程_启动 (&多线程, , )

.否则

信息框 (“窗口绑定失败”, 0, )

.如果结束

.子程序 _按钮2_被单击

.如果真 (线程句柄 > 0)

线程_挂起 (线程句柄)

.如果真结束

.子程序 _按钮3_被单击

.如果 (线程句柄 > 0)

线程_恢复 (线程句柄)

.否则

.如果结束

.子程序 _按钮4_被单击

.局部变量 返回值, 整数型

.如果真 (线程句柄 > 0)

返回值 = TS.UnBindWindow ()

调试输出 (“窗口解除绑定返回值:”, 返回值)

线程_退出许可区 (许可证)

线程_删除许可证 (许可证)

强制结束线程 (线程句柄)

.如果真结束

.子程序 多线程

.子程序 _按钮5_被单击

TS.Capture (0, 0, 1024, 768, “测试.bmp”)

谢谢大家留言互粉!

相关内容推荐