ruby on rails + mysql 开发环境搭建

ror对于初学者来讲,可能最大的困难莫过于开发环境的安装与搭建,今天折腾了大半天基本搞定了,把过程贴在这里,以便初学者少走弯路。1.安装ruby 1.8.6 打开  http://rubyforge.org/frs/?group_id=167 ,安装 ruby1.8.6-26最终版本
下载完成后,可在命令行下键入 ruby -v验证版本 (如果在命令行里输入ruby提示找到不该命令,请将c:rubybin加入到path环境变量中2.安装rails,命令行键入: gem install rails不知道什么原因,我的机器(windows 2008 sp2)上一直提示如下错误:关闭防火墙也是如此,看来肯定不是网速原因,无奈之下,重新下载了另一个版本(仍然在刚才那个下载界面):
 覆盖安装完成以后,再次运行gem install rails,居然可以了(不过该过程要联网下载,时间会比较长),完成后,命令行键入rails -v 验证版本

3.安装mongrel
(相当于asp.net开发中的IIS,在网上看到有说IIS上也可以跑ROR,不过没试过)
命令行: gem install mongrel (有关mongrel的更多操作,可以参照这篇文章:http://hi.baidu.com/camark/blog/item/10958516dce12d52f3de32c9.html)
4.创建测试rails测试项目:
命令行: rails c:workhello 该命令将在c:work目录下,创建一个测试项目hello启动该项目测试一下(命令行输入如下命令):c:cd workhello mongrel_rails start -d成功后,mongrel服务器将在本机3000端口监听http请求,访问http://localhost:3000/ 试下,如果出现以下画面,则rails环境基本ok了
这里可以看到rails项目默认使用的是SQLite做为数据库,点击"About your application’s environment"将显示如下信息:
如果您的机器上无法显示该信息,多半是c:rubybin目录中没有sqlite3.dll文件(可在http://rubyforge.org/frs/?group_id=904 下载InstantRails-2.0-win.zip解压后得到),当然如果想使用mysql做为数据库的话,继续往下看 5.安装mysql5.1 百度“mysql下载”第一个便是下载地址:http://download.mysql.cn/src/2008/1201/5556.html,按步就班的一步步安装,注意语言选择,建议选utf8提示:最好安装4.1或5.0版本,不要安装最新的5.1版本,rails框架对5.1版本的mysql支持并不好,在rake db:migrate时总提示出错5.2 找一款适合自己的mysql管理工具,如果你是php程序员,phpmysqladmin也许很适合你,如果你象我一样只喜欢iis,机器上没有php环境,SQLyog Enterprise 将是一个不错的选择(迅雷一下就能找到“特别版”,呵) 6.配置ruby下的mysql连接6.1 把Mysql安装目录中bin目录下的libmysql.dll 复制到ruby安装目录的bin目录下(一般是c:rubybin下)6.2 到http://rubyforge.org/frs/?group_id=627 下载rdoc-2.4.3.gem (注意:只能用迅雷下,直接另存为后,文件后缀名将变成非.gem的东东),然后把rdoc-2.4.3.gem复制到c:rubydown下(down目录是我自己建的),然后命令行: cd c:rubydown gem install rdoc-2.4.3.gem此举是为了后面顺利安装mysql for ruby的文档6.3 安装mysql for ruby的驱动,命令行键入: gem install mysql6.4 把mysql.so复制到C:rubylibrubysite_ruby1.8i386-msvcrt下(mysql.so文件如果本机找不到,可在http://rubyforge.org/frs/?group_id=904 下载InstantRails-2.0-win.zip解压后得到)然后就可以在代码中连接了: )
其它问题请参见:司徒正美先生的 

相关内容推荐