windows 上rails3.2 + ruby1.9环境搭建

1.搭建环境准备ruby1.9.3下载地址:下载地址:http://rubyforge.org/frs/?group_id=167   edit 20140102a、安装版http://rubyforge.org/frs/download.php/76952/rubyinstaller-1.9.3-p429.exeb、源文件版http://rubyforge.org/frs/download.php/76953/ruby-1.9.3-p429-i386-mingw32.7z 下面按两种方式分别附上安装步骤: ******************************************a、安装版(rubyinstall)******************************************1、首先需要下载Ruby Installer:下载rubyinstaller-1.9.3-p429.exe之后,双击,一路next,其中一步设置环境变量,选中复选框就ok。装完后可以cmd输入ruby -v查看ruby版本号,同时验证自己是否安装成功。2、安装rubygems:下载地址:http://rubyforge.org/frs/download.php/75710/rubygems-1.8.15.zip下载后解压缩,进入目录,双击 ruby setup.rb安装rubygems。3、安装DevKit:
下载地址:http://rubyinstaller.org/downloads/
下载文件:
DevKit-tdm-32-4.5.2-20111229-1559-sfx.exe,
DevKit是windows平台下编译和使用本地C/C++扩展包的工具。
它是用来模拟Linux平台下的make,gcc,sh来进行编译,如果没有安装这个的话,
后面会遇到一堆麻烦。下载完双击,文件夹选择ruby在自己电脑上的安装路径。
比例如是 C:Ruby193DevKit。
在cmd里进入DevKit目录后输入ruby dk.rb init
显示了当前安装的Ruby处理系统,在DevKit展开文件夹中生成了初期设定的文件 (config.yml),这个是初期文件,要人为修改(如何修改,见下文(devkit 安装时的config.yml配置文件的修改)),否则config.yml会无效
继续输入ruby dk.rb install
这一步执行完,DevKit便安装完毕。
4、Rails 的安装。Ruby on Rails是由Ruby处理系统的类库的、
通过使用  RubyGems,很容易的来进行安装/卸装
启动命令:gem install -v=3.2.3 rails过程可能比较久,需要等待。安装完后可以输入命令:rails -v查看rails版本,同时确认是否安装成功。5、创建演示程序
 rails new rails3 -d mysql

6、创建数据库(如果报没有libmysql.dll,可以从mysql/bin下copy到ruby/bin目录下,见下文(mysql错误)
 rake db:create

7、启动中间件(rails3目录下)
 rails server

说明:在完全启动中间件的过程中有可能会报错提示有些gem没安装,你们可以gem install  gem名 在线安装。

 

*****************************************b、源文件版*****************************************1、安装ruby 1.9.32、gem install rails --version 3.2.3 3、安装mysql gem install mysql4、创建演示程序
 rails new rails3 -d mysql5、创建数据库(如果报没有libmysql.dll,可以从mysql/bin下copy到ruby/bin目录下,见下文(mysql错误)
 rake db:create RAILS_ENV=development

6、启动中间件(rails3目录下)
 rails server说明:在完全启动中间件的过程中有可能会报错提示有些gem没安装,你们可以gem install  gem名 在线安装。 2、搭建环境中的错误处理方法  a。devkit 安装时的config.yml配置文件的修改    错误描述:当通过ruby dk.rb init 是会生成config.yml文件;当我们在执行ruby dk.rb install时,或许会出现错误信息:    Invalid configuration or no Rubies listed. Please fix 'config.yml' and rerun 'ruby dk.rb install'    解决方案:打开config.yml文件,在最下面加入你安装的ruby路径,重新执行ruby dk.rb install命令    如图:     b。mysql错误   已安装mysql5.1后,在C:Program FilesMySQLMySQL Server 5.5liblibmysql.dll,将文件拷贝到Ruby的安装路径下E:ruby193_232ruby-193bin。   错误描述:Incorrect MySQL clie nt library version! This gem was compiled for 6.0.0 but the client library is 5.5.20. Mysql client的版本没对应造成的,gem要求的版本是6.0.0的,但是clent才5.5.20   解决方法:到Mysql官网:http://dev.mysql.com/downloads/connector/c/6.0.html下载对应的版本。安装到MySQL目录下   然后cmd:  gem pristine mysql2 -- --with-mysql-config=e:mysql-connector-c-noinstall-6.0.2-win32,如果你项目没用到mysql2的话,就这一步可以省略。     把C:Program FilesMySQLMySQL Connector 6.0.2liblibmysql.dll 拷贝到Ruby的安装路径下C:Ruby193bin下,重新编译。  3、参考资料(谢谢!)    http://eliot1028.blog.51cto.com/6966437/1177096    http://my.oschina.net/shootercn/blog/16014     

相关内容推荐